This repository has been archived on 2022-01-17. You can view files and clone it, but cannot push or open issues/pull-requests.
recipes/service/recipe.spec

20 lines
536 B
Plaintext

name: service
version: 0.0.1
sources: https://git.karchnu.fr/WeirdOS/service/archive/75e500adcf75b8cf0210a7271cdd5a9109988eae.tar.gz -> %{name}-%{version}.tar.gz
build-dependencies: crystal, build.zsh, make, git, libyaml-dev, libyaml, spec-parser
# FIXME: FIXME: Build this statically in.
dependencies: gc, libevent, pcre
dirname: service
@configure
cd %{dirname}
build.zsh -c
@build
cd %{dirname}
CRYSTAL_PATH="$(crystal env CRYSTAL_PATH):lib" make PREFIX=/usr
@install
cd %{dirname}
make PREFIX=/usr DESTDIR="%{pkg}" install